通达信同图显示了MACD,KDJ和市场多空能量幅图公式

表达的源代码:

A:=CURRBARSCOUNT;

A1=天!REF(天,1);

A2:= barslast(A1) 1

A3: = MA(C),A2)

A4:=总和(AMO,A2)/和(VOL),A2)/ 100

A5:IF(资金>0),A4,A3)

调和线=

分钟的无效周而复始:=If(周而复始=2),15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,DRAWNULL))));

价钱点:= tfilt(关,CURRBARSCOUNT,00,CURRBARSCOUNT,00);

当断定:假如drawnull价钱(子= =,1,假如(分钟无效周而复始= drawnull),DRAWNULL,1));

{MACD场所顶底}

差值:= EMA(打烊),12)-EMA(打烊),26);

DEA:= EMA(离题),9);

MACD:=2*(DIFF-DEA);

KX:= barssince(关)-一号从收盘价钱;{ }天G

和:=常数(HHV(diff,KX)

HLN:=常数(LLV(DEA,KX)

RC1:=CONST((HHN+HLN)/2);

SS:=((hhn-hln)/ 200)

MACD生根:=(-100*SS+RC1)+-(-100*SS+RC1),COLOR669999;

MACD顶部:=(100*SS+RC1)+-(-100*SS+RC1),COLORFF0033;

MACD轴心国:=0+-(-100*SS+RC1);

DIFF合适的:=DIFF+-(-100*SS+RC1),COLOR008080;

DEA合适的:=DEA+-(-100*SS+RC1),COLOR00FF00;

MACD修正:=2*(离题合适的- DEA修正) MACD轴心国,COLOR0000BB,NODRAW;

MACD:= const LLV(MACD(超跌合适的,KX)

MACD = MACD(超卖线:超卖){应用MACD走向停止精密的的生根断定

顶部:= MACD顶部 MACD超卖线

轮廓线=顶部

轴:= MACD轴 MACD超卖线

海=顶部

生根:= MACD的生根

{全体与会者KDJ规范合并的MACD使尽可能有效}

RSVA:=(CLOSE-LLV(LOW,21))/(HHV(高,21)- LLV(低,21)*TOP;{应用21天行使尽可能有效}

K:SMA(RSVA,3,1),COLORFFFFFF,NODRAW;

D:SMA(K,3,1),COLOR00FFFF,NODRAW;

如此的J值参量:= 3 *个* D

JD:= IF(原始J值参量)

J:假如(JD> TOP),顶部,JD),COLORFF00FF,nodraw;{生根非竞选运动化,话说回来在顶部非竞选运动化。

{MACD多空量能断定}

MACD长:离题合适的 MACD超卖线,COLOR339999;

使碰到某物:DEA合适的 MACD超卖线,COLOR00FF00;

测柱:2×(MACD多头-空) 轴心国线,COLOR0000BB,NODRAW;

在DEA预先阻止=(EMA(MACD多首长)),7));

正向MACD:=2×(MACD多头超前DEA) 轴心国线

{首要课程潮流}

大板块:var1 = LLV(低,13);

VAR2大板块:= HHV(高,13);

VAR3杯:=(SMA((CLOSE-VAR1杯)/(VAR2杯-VAR1杯)*顶部,5,1))-顶部/2;

VAR4杯:=SMA((VAR2杯-CLOSE)/(VAR2杯-VAR1杯)*顶部,5,1)-顶部/2;

散装批发:=假如(Var4杯子)

首要义卖市场:=假如(var3杯子)

{聚集的本钱打破}

最大盈利参量:= TOP/100

var1c:=(本钱(89)本钱(11))×盈利最大值化参量

var2c:=(本钱)-本钱((1))×盈利最大值化参量

单峰:=((1-var1c / var2c))*顶

低密:=((COST(90)-COST(60))/VAR2C)*顶部;

高密度:=((本钱(40)本钱(1))/ var2c)*顶

盈利:= (SMA(赢家(等同/卷/ 99)),2,1)*顶部

竞选运动:顶上/(1 EXPMA(HSL),21)),color774455;发哥{ – }大众热心追逐索引

70%本钱:=假如浓度(var1c >上),顶部,VAR1C),COLORFFFFFF;

90%本钱:=假如浓度(var2c >上),顶部,VAR2C),COLORFF0000;

牢狱筹休会:=(单峰盈利)>生根,(单峰盈利),生根)

私人的股:=,顶部,牢狱筹高潮,COLOR408000;

批发:假如(市场占有率批发= drawnull),DRAWNULL,私人的股),COLOR408000;

盈利增长:=(盈利单峰)>生根,(盈利-单峰),生根)

首要市场占有率:,顶部,高涨利市筹,COLOR330088;

主力:假如(= drawnull,主力的市场占有率,DRAWNULL,市场占有率主力军,COLOR330088;

{周转率,五日周转率附带断定个股教育活动度}

换手:SUM(VOL,1)/CAPITAL*100,COLOR666666,NODRAW;

⑤日换:SUM(VOL,5)/CAPITAL*100,COLOR999999,NODRAW;

{聚集本钱打破索引峰值绘制线}

金本位的的语境修饰1:STICKLINE(C > 0 AND CURRBARSCOUNT>=2,顶部,生根,),COLOR003333;

金本位的的语境修饰2:STICKLINE(C > 0 AND CURRBARSCOUNT>=2,顶部,轴心国,),COLOR003333;

金本位的语境粮食:drawband(上,RGB(51,51,0),轴心国,RGB(51,51,0));

金本位的的语境:drawband(上,RGB(51,51,0),生根,RGB(128,128,128));

追:drawband(紫罗兰色的热峰竞选运动,RGB(66,52,81),生根,RGB(204,0,0));

高弥缝蓝色墨水:= drawband(高密度,RGB(0,0,51),生根,RGB(0,0,255));

低密度峰值纯蓝:= drawband(低密度),RGB(0,0,102),生根,RGB(0,0,255));

90%本钱峰:DRAWBAND(90%本钱集合度,RGB(0,0,153),生根,RGB(0,0,153));

70%本钱峰:DRAWBAND(70%本钱集合度,RGB(0,128,0),生根,RGB(255,255,255));

绿色:drawband(批发批发顶峰,RGB(0,64,0),生根,RGB(204,0,0));

主峰红:drawband(主力),RGB(102,26,51),生根,RGB(0,0,255));

MACD多空走向:DRAWBAND(MACD多头,RGB(204,51,51),名义上的,RGB(0,179,0));

MACD多头重画:DRAWBAND(MACD多头,RGB(153,153,51),MACD多头,RGB(153,153,51));

MACD名义上的重画:DRAWBAND(名义上的,RGB(0,204,0),名义上的,RGB(0,204,0));

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);

VAR2:=REF(VAR1,1) AND CLOSE=REF(CLOSE,2);

VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE

VAR4:=REF(VAR3,1) AND CLOSE=REF(CLOSE,2);

VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE

VAR6:=REF(VAR5,1) AND CLOSE=REF(CLOSE,2);

VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE

VAR8:=REF(VAR7,1) AND CLOSE=REF(CLOSE,2);

VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE

哈佛:=打烊费尔:= REF(Vard,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE

:=(V REF varf,1) AND CLOSE=REF(CLOSE,2);

VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE

VAR11:=REF(VAR10,1) AND CLOSE=REF(CLOSE,2);

VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE

VAR13:=REF(VAR12,1) AND CLOSE=REF(CLOSE,2);

VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE

VAR15:=REF(VAR14,1) AND CLOSE=REF(CLOSE,2);

VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE

VAR17:=REF(VAR16,1) AND CLOSE=REF(CLOSE,2);

VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE

三平板龙骨翻金:=(REF(码) ORVAREOR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1))

AND VAR1;

首要发出刮擦声:,5),COLORFFFFFF;

主力洗盘线:=马(V,35),COLOR00FFFF;

外资基金限制:,135),COLORFF0000;

{买东西证明人}

(十字)(主发出刮擦声),基金替换线 OR ((主力洗盘线 >基金替换线 AND 穿插(主辅助的线),主力洗盘线),COLORYELLOW;

启动:=(主发出刮擦声> REF(主发出刮擦声),1) AND (穿插),首要的发出刮擦声 AND (卷),1)复兴:=三平板龙骨黄金周转 AND (袭击) 或启动)

够支付心情:=假如(设置=1),许多*) 时期断定=1

{顶线,轮廓线,许多线,基线重画}

顶线:drawband(上,RGB(51,0,255),顶部,RGB(51,0,255));

轮廓线:drawband(视平线),RGB(128,64,64),天边,RGB(128,64,64));

许多线:drawband(许多),RGB(0,153,153),许多,RGB(0,153,153));

基线:= drawband(0,RGB(153,153,102),够支付心情,RGB(153,153,102));

{在MACD多空量能柱}

MACD红柱前1:STICKLINE(MACD >前桥,在MACD,轴心国,),COLOR226688;

MACD红柱前2:STICKLINE(MACD >前桥,在MACD,轴心国,),COLOR4488BB;

在MACD红柱3:STICKLINE(在MACD>=轴心国,在MACD,轴心国,),COLOR55AADD;

在MACD兰柱1:STICKLINE(在MACD

在MACD兰柱2:STICKLINE(在MACD

在MACD兰柱3:STICKLINE(在MACD

{MACD多空量能柱}

MACD红柱1:STICKLINE(量能柱>=轴心国,量能柱,轴心国,),COLOR000077;

2:当MACD红柱体积(>柱被停业,量能柱,轴心国,),COLOR000088;

3:当MACD红柱体积(>柱被停业,量能柱,轴心国,),COLOR000099;

4:当MACD红柱体积(>柱被停业,量能柱,轴心国,),COLOR0000AA;

1:当MACD蓝柱(梁能竹

2:当MACD蓝柱(梁能竹

3:当MACD蓝柱(梁能竹

4:当MACD蓝柱(梁能竹

轴和重画的顶线,轮廓线,许多线,生根线,多行文本}

中纺锤:drawband(轴心国线),RGB(128,128,255),轴心国,RGB(128,128,255));

顶部线刻:DRAWTEXT(CURRBARSCOUNT=1,顶部*,”顶部线”),COLORFF0033;

轮廓线刻:DRAWTEXT(CURRBARSCOUNT=1,天边*,”轮廓线”),COLOR404080;

许多线刻:DRAWTEXT(CURRBARSCOUNT=1,许多,”许多线”),COLOR999900;

生根线刻:DRAWTEXT(CURRBARSCOUNT=1,生根,”生根线”),COLOR669999;

轴心国线刻:DRAWTEXT(CURRBARSCOUNT=1,轴心国,”多空线”),COLORFF8080;

{全体与会者KDJ规范线重画}

D线重画:DRAWBAND(D,RGB(255,255,0),D*(255,255,0));

K线重画:DRAWBAND(K,RGB(255,255,255),K,RGB(255,255,255));

J线:DRAWBAND J(转载,RGB(255,0,255),J,RGB(255,0,255));

发表评论

电子邮件地址不会被公开。 必填项已用*标注